Categories
Uncategorized

The black.vim plugin requires vim7.0+ with Python 3.6 support.

MacのterminalのVimでPythonフォーマッターのBlackを使おうとしたら、タイトルのようなエラーが出たのであれこれしましたが、結局

$ brew install vim

で/opt/homebrew/bin/vimを使えば解決しました。/usr/bin/vimだとMacに標準のpython2.7が起動していた模様。そちらをどうやって直すかまでは調べてません。

Leave a Reply

Your email address will not be published.